Cant seem to install STS on Mac, My Java is too new?

Ask questions and discuss programming issues around Tatool Java.
Locked
rouderj
Posts: 1
Joined: Sun Apr 20, 2014 9:37 am
Institution: University of Missouri

Cant seem to install STS on Mac, My Java is too new?

Post by rouderj » Sun Apr 20, 2014 9:46 am

Hi All,

I am an old dog at computer psychology experiments, but sometimes old dogs have a hard time learning new tricks. I am coming from a C (in dos) and psychophysical toolbox (in Mac and Linux) background. We run Mac and Linux boxes in our lab. I am looking to deliver stand-alone java executables over the web to experimenters in other labs to execute my experiments.
tatool looks really promising, so I was bummed when I tried to install tatool and failed. The problem is STS, which, I have no idea what it does, and the problem is that my java se is 8 and it wants 6. can someone help?

Thanks,
Jeff

ps visited Klaus Oberaur at Zurich last summer and had a great time.

StoneJ
Posts: 50
Joined: Thu Aug 29, 2013 10:39 am
Institution: University of Lancaster, UK

Re: Cant seem to install STS on Mac, My Java is too new?

Post by StoneJ » Mon Apr 21, 2014 4:09 am

Hi,

Thought I would try and be of some use. STS is an integrated development environment, I was using Eclipse before and it seems that STS is essentially Eclipse but with a few plugins that come with it by default (there may be more to the difference between the two but as an amateur programmer I can't see much else).

As far as I am aware Java 8 is still very new therefore it is quite likely a lot of applications are not ready to support it. You could go to the java archive page http://www.oracle.com/technetwork/java/ ... 39210.html and download other versions of the SDK, perhaps 6 or 7. You can have multiple versions of the SDK on your machine and tell STS which one to use. So perhaps if you install version 6 along with what you currently have then STS will find and not break.

Hope this was some help,


James

cvonbastian
Posts: 185
Joined: Tue Apr 24, 2012 8:22 am
Institution: Bournemouth University

Re: Cant seem to install STS on Mac, My Java is too new?

Post by cvonbastian » Sun Apr 27, 2014 7:28 am

Hi Jeff

Great to hear that you're giving Tatool a try! I remember your visit in Zurich well as I greatly enjoyed your talk. :-)

As James pointed out, STS is an IDE that assists you in programming - somewhat similar to Matlab or R studio (e.g., it also features auto-complete of methods and automatic intendation etc.). As Tatool uses the Spring framework in several parts of its architecture, the STS (-> Spring Tool Suite) provides useful features when working with Tatool (e.g., you can click on elements in the Module XML files and jump directly to your executable in your project).

I now added some instructions (see here for an overview) that hopefully helps when installing the JDK, STS and finally the "Examples" project comprising some experimental paradigms (e.g., a complex span task):
  1. 1. Installing the JDK
I just tried out whether the newest version of STS (maybe you used one that's older than 3.5.0?) works in connection with JDK 8. It seems to run without any problems. You can also download newer/older versions of the JDK, keep them all installed and change the JDK path to that specific version you want to use after you've installed the STS. To do so, go to "Window" in the menu and select "Preferences".

In the menu on the left side, you have to go to "Java" and then "Installed JREs". It should look similar to this window:
Image

Select "Add" on the right and then "Standard VM", as in here:
Image

Next, choose the path to the JDK version you want to use, resulting in a listing of the system libraries such as this:
Image

Finally, tick the checkbox next to the JDK you want to use to set it as default:
Image

Let us know whether that worked, otherwise we'll be happy to help!

Claudia

Locked

Who is online

Users browsing this forum: No registered users and 1 guest